Alle Kinsta-klienter kan nemt opdatere og eller ændre PHP-versioner for hvert WordPress-sted hver for sig i MyKinsta-instrumentbrættet. I øjeblikket understøtter vi PHP 7.2, 7.3 og 7.4 til websteder, der er hostet på Kinsta.

Vi anbefaler stærkt PHP 7.3 eller den nyeste version 7.4, da det er meget hurtigere, ressourcevenligt og mere sikkert end dets forgængere. Det er faktisk vist, at det er 3 gange så hurtigt i nogle konfigurationer, som det ses i vores PHP-benchmark-rapporter.

Som du måske har hørt, er PHP flyttet til en forudsigelig frigivelsesplan. Hver nye version vedligeholdes aktivt i 2 år og modtager et yderligere år med kritiske sikkerhedsopdateringer. For at sikre, at dine WordPress-websteder er så hurtige og sikre som muligt, har vi vedtaget den samme tidsplan, hvilket betyder, at vi fjerner ikke-understøttede versioner af PHP, når de når slutningen af ​​livet. (EOL)

Ikke kun vil vi vedtage PHP’s officielle tidsplan, men fra og med 2020 vil levetiden for den ældste version af PHP på Kinsta-platformen altid være 1. november. Dette giver dig og vores team mulighed for at opgradere alle inden feriesæsonen (Black Friday, Cyber Monday, jul, etc.).

Hvorfor opdatere din PHP-version?

De to hovedårsager er sikkerhed og hastighed.

Ligesom du opgraderer WordPress selv for at sikre dig, at du er beskyttet mod sikkerheds-sårbarheder, skal du gøre det samme med PHP. Derudover producerer opgradering af PHP en betydelig hastighedsforøgelse. PHP 7.0 var et stort spring fremad – mere end fordobling af ydelsen sammenlignet med 5,6. Med version 7.3 har vi set yderligere 20% – 25% stigning sammenlignet med 7.0. 7.4 viser også præstationsforbedringer over 7.3 .

For yderligere oplysninger, se vores artikel om understøttede PHP-versioner.

Ikke sikker på, hvilken version af PHP du kører? Du kan tjekke i menuen “Værktøjer” i MyKinsta dashboardet. Eller, hvis du kører WordPress 5.0 eller nyere, kan du se PHP-versionen under “Site Health” -værktøjet.

WordPress site health tool PHP version

WordPress site health tool PHP versioner

Hvad hvis mit websted bryder?

Problemer forårsaget af opdatering af PHP-versioner opstår, når koden, der kører på dit websted, bruger gamle funktioner, der ikke længere understøttes af nyere PHP-versioner. Den skyldige vil sandsynligvis være et plugin eller et aktivt tema. Vores guide nedenfor indeholder trin-for-trin-instruktioner om, hvordan du løser problemet.

Aktivér debugtilstand i MyKinsta

I dag vil vi lede dig gennem trinnene til, hvordan du bedst tester dit WordPress-sted for kompatibilitet, før vi opdaterer PHP-versioner. Mange af jer bør ikke opleve nogen nedetid, og der kræves lidt arbejde.

For andre kan det være nødvendigt med yderligere test, fejlfinding og endda ansættelse af en WordPress-udvikler for at gøre tingene kompatible.

Hvis du blot ønsker at opdatere PHP-versionen på dit levende miljø med det samme, kan du springe ned til trin 2. Vi anbefaler dog kraftigt at følge alle nedenstående trin dog for at sikre, at alt fungerer korrekt.

Især hvis du kører en ældre version, f.eks. PHP 5.6.

Trin 1 – Opret et scenesite

Den allerførste ting, du skal gøre, er at oprette et scenesite. Dette er adskilt fra dit live-miljø og giver dig mulighed for at teste nyere versioner af PHP uden at ødelægge dit live-site.

I MyKinsta-betjeningspanelet skal du klikke på “Websteder” i venstre navigation. Du vil se en liste over dine websteder. Klik på den, du gerne vil tilføje et scene område til (det websted, du vil opdatere PHP-versioner på). Klik på “scenemiljø” i rullemenuen øverst til højre, og klik derefter på knappen ”Opret et scenemiljø”.

Opret et WordPress scenesite i MyKinsta.

Opret et WordPress scenesite i MyKinsta.

Sørg for også at tjekke de vigtige bemærkninger vedrørende scenemiljøer. For eksempel, hvis du bruger et tredjeparts CDN, skal du muligvis deaktivere det for at dit websted skal gengives korrekt.

Dette skyldes, at dit scenesite bruger en anden URL. Cache er også deaktiveret ved iscenesættelse, så husk dette, hvis du prøver at teste ydeevne.

Trin 2 – Opdater PHP-version af WordPress

For at opdatere dit WordPress-websteds PHP-version skal du gå til “Websteder” og vælge det sted, du gerne vil ændre PHP-versionen på. Klik derefter på fanen “Værktøjer“. Klik på rullemenuen under “PHP Engine” og vælg din foretrukne PHP-version.

Hvis du først vil teste en ny PHP-version, skal du sørge for, at dit scenemiljø er valgt, ikke dit live miljø. Vi anbefaler første test med PHP 7.4. Hvis dit websted har problemer, kan du altid vende det tilbage til en lavere version, f.eks. PHP 7.2.

Skift PHP-version i MyKinsta..

Skift PHP-version i MyKinsta.

Når du vælger den ønskede PHP-version, får du en meddelelse. Klik på knappen “Modificer PHP-version” for at bekræfte dit valg.

Rediger bekræftelse af PHP-version

Rediger bekræftelse af PHP-version

Denne proces kan tage op til 3 minutter. Ved afslutningen af ​​processen genstartes din PHP-motor, hvilket kun kan resultere i et par sekunders nedetid for din WordPress-backend. Besøgende på dine websteder vil ikke opleve nogen nedetid.

Mens PHP-versionen ændres, kan du navigere væk fra ovenstående side, men nogle handlinger som cache-håndtering vil være utilgængelige, indtil den nye motor er aktiveret. Du vil modtage en anmeldelse i betjeningspanelet, så snart ændringen er foretaget.

Trin 3 – Test dit websted, plugins, tema

Du skal nu have et scenesite kørt på den nyeste version af PHP (eller den version, du vil skifte til). Den første ting, du skal gøre, er blot at browse og klikke rundt på dit WordPress-sted for at se, om du bemærker noget ødelagt.

Hvis noget er uforeneligt, f.eks. Et plugin eller dit tema, kan du muligvis se en 500 error eller en dødens hvide skærm i front-end af dit websted. I dette tilfælde er den nemmeste og hurtigste måde at bestemme, hvad der kan forårsage det, at deaktivere alle dine tredjeparts plugins og genaktivere dem en efter en. Husk, at du er på et scenesite. Så du behøver ikke at bekymre dig om at bryde noget.

Vælg alle dine plugins i dit WordPress-kontrolpanel under “Plugins” -skærmen. Vælg derefter “Deaktiver” fra rullemenuen, og klik på “Anvend.”

Sådan deaktiveres WordPress-plugins bulk fra dashboardet

Sådan deaktiveres WordPress-plugins bulk fra dashboardet

Du kan derefter aktivere dem én efter én ved at besøge dit WordPress-sted hver gang. Dette vil hjælpe med at indsnævre det, der muligvis forårsager et problem. Har du ikke adgang til dit WordPress dashboard på grund af en fejl? Intet problem. Tjek, hvordan du deaktiverer plugins via FTP.

Præcis samme test kan bruges med dit WordPress-tema. Du kan midlertidigt skifte tilbage til standard WordPress-temaet, såsom Twenty Nineteen-temaet.

Se logfiler i MyKinsta

Måske har du bestemt, hvilket plugin eller tema, der forårsager problemet, men ikke sikker på hvorfor? Det er her dine WordPress error oggs kan blive nyttige. Klik blot på et af dine WordPress-websteder og til højre klik på “Error logfiler.”

Du kan se dine error.log-, kinsta-cache-perf.log- og access.log-filer. Som standard viser det de sidste 1.000 linjer. Du kan trække skyderen over for at se de sidste 20.000 linjer.

View PHP errors in MyKinsta.

Se PHP-fejl i MyKinsta.

Vigtigt: Værktøjet MyKinsta-logfiler viser ikke fejlfindingsinfo. Hvis du har brug for at få vist fejlfindingsoplysninger, kan du aktivere WP_DEBUG, som vi viser dig nedenfor.

Se raw log filer via SFTP

Du kan se de fuldstændigt umodificerede logs /logs/ via SFTP.

WordPress error logs mappe via SFTP

WordPress error logs mappe via SFTP

Skræddersy dine logfiler via SSH

Du kan skræddersy logfilerne, mens du eksperimenterer på dit websted ved hjælp af SSH. Dette betyder dybest set, at du kan se logopdateringen live, mens du tester. Alle Kinstas hostingplaner inkluderer SSH-adgang.

Vis de sidste 500 linjer

tail -n 500 /www/sitename/logs/error.log

Se filen live

Se din opdatering af ferror logfil på farten.

tail -f /www/sitename/logs/error.log

For dem af jer med SSH-adgang kan WP-CLI også være et uvurderligt værktøj.

Kæmper du med stilletidsproblemer og WordPress-problemer? Kinsta er hostingløsningen designet med ydelse og sikkerhed i tankerne! Tjek vores planer

Aktivér debugtilstand i MyKinsta

For Kinsta-brugere kan WordPress-debugtilstand aktiveres lige i MyKinsta-dashboardet. Naviger blot til Sites> Værktøjer> WordPress Debugging, og klik på knappen “Aktiver”. Dette giver dig mulighed for at se PHP fejl og meddelelser uden at skulle aktivere debugtilstand via SSH eller SFTP

Aktiveret debugtilstand i MyKinsta.

Aktiveret debugtilstand i MyKinsta.

Vores selvhelende PHP-funktion genstarter automatisk PHP, hvis den bemærker problemer. Hvis du har brug for at genstarte PHP manuelt af en eller anden grund, kan du gøre det ved at gå til dit websteds værktøjsside og klikke på Genstart PHP.

Genstart PHP i MyKinsta dashboard

Genstart PHP i MyKinsta dashboard

Aktivér debug logging i WordPress

Hvis du ikke har SSH eller MyKinsta-adgang, kan du altid aktivere fejlsøgning i WordPress. Først skal du oprette forbindelse til dit websted via SFTP. Download derefter din wp-config.php, så du kan redigere den.

Download wp-config.php-fil

Download wp-config.php-fil

Find den linje, der siger /* That's all, stop editing! Happy blogging. */ og lige før det skal du tilføje følgende (som det ses nedenfor):

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );
Aktivér debug logging i WordPress

Aktivér debug logging i WordPress

Hvis ovenstående kode allerede findes i din wp-config.php fil, men er indstillet til “false, skal du blot ændre den til “true”. Dette aktiverer debugtilstand og viser alt i din /wp-content/debug.log-fil. Du vil også se advarsler og fejl i din WordPress-administrator, hvis de findes.

Vigtigt: Glem ikke at slå det fra, når du er færdig, da disse filer kan blive temmelig store meget hurtigt.

Forvirret over hvad man skal kigge efter?

Der er tusinder af plugins og temaer derude, så det er desværre umuligt for os at liste alle de fejl, du måtte opleve. Disse forekommer typisk på grund af, at kode (funktioner, syntaks osv.) Er uforenelig med den version af PHP, du bruger. Her er dog et eksempel på noget, du måske ser.

500: Fatal error: Uncaught Error: A semicolon (';') is expected here. in /www/sitename/public/wp-content/plugins/bbpress-shortcodes/bbpress-shortcodes.php:177

Som du kan se ovenfor, er det temmelig let hurtigt at indsnævre, at det er bbPress Shortcodes-plugin, der forårsager et problem.

I værste tilfælde kan du muligvis opleve, at du har et kompatibilitetsproblem med en eller to plugins. Hvis det er tilfældet, er det her, vi anbefaler:

  1. Opdater dine plugins og temaer til den nyeste version, hvis du ikke allerede har gjort det.
  2. Henvend dig til udvikleren af ​​plugin eller tema og bede dem om at tilføje / rette support PHP 7.4 (eller den aktuelle version, du bruger). Dette er en af ​​grundene til, at vi giver dig et heads-up inden udfasnings-datoen!
  3. Find et alternativ plugin, der kan levere den samme funktionalitet og er kompatibel med PHP-versionen.
  4. Ansæt en WordPress-udvikler for at løse problemet.
  5. Skift din PHP-motor til en lavere version og se, om plugin eller tema derefter fungerer. Hvis det gør det, kan du køre på en lavere version af PHP, indtil udvikleren opdaterer deres kode. Vi anbefaler ikke dette, da PHP 7.4 er hurtigere og forbliver understøttet i en længere periode. Men hvis der er noget, du absolut har brug for at køre, og det kun fungerer på PHP 7.2, er du muligvis nødt til at ty til dette.

Trin 4 – Skub scene live

Når du er færdig med at teste dit websted med PHP, kan du enten skubbe scene live eller foretage eventuelle nødvendige ændringer på livewebstedet og derefter ændre PHP-versionen på dit live-site.

Nogle af jer finder måske ud, at du er nødt til at foretage nogenlunde udtømmende ændringer i scenen for at få webstedet til at køre på en nyere version af PHP. I dette tilfælde sparer du meget tid ved at bruge funktionen push to live.

For at gøre dette skal du sikre dig, at du har valgt dit scenemiljø. Klik derefter på knappen “Tryk scene live”.

Skub WordPress scenemiljø live.

Skub WordPress scenemiljø live.

Du er velkommen til at kontakte vores supportteam 24/7 angående problemer eller problemer med opdatering af PHP-versionen på dit WordPress-websted.


Hvis du kunne lide denne vejledning, så vil du elske vores support. Alle Kinstas hostingplaner indeholder 24/7 support fra vores erfarne WordPress-udviklere og ingeniører. Chat med det samme team, der understøtter vores Fortune 500-kunder. Tjek vores planer