WordPress 5.1 “Betty” fue oficialmente lanzado el 21 de febrero de 2019, y está disponible para ser descargado.

WordPress 5.1 es el primer  lanzamiento importante desde el lanzamiento del editor de bloques de WordPress (Gutenberg) en WordPress 5.0. Y si bien trae ciertos retoques y mejoras para el editor de bloques, las características más importantes de esta versión incluyen el proyecto Site Health de WordPress  y también notificaciones para algunas versiones de PHP.

Actualización: Novedades en WordPress 5.3

En este artículo, veremos algunas de las nuevas funciones que podrían afectarle a la forma en que usted utiliza WordPress:

Nuevo Aviso del Dashboard para la Versión de PHP

En Kinsta, siempre recomendamos utilizar las versiones más recientes de PHP para un desempeño y seguridad mejorada.

De nuestros benchmarks, PHP 7.3 es en promedio, un 9% más rápido que PHP 7.2. Y si usted compara PHP 7.3 a PHP 5.6, ¡este puede lidiar con casi 3 veces más peticiones (transacciones) por segundo! Siempre debería hacer pruebas a los plugins y temas en su entorno de staging, para chequear la compatibilidad. Si todo está en orden, asegúrese de tomar ventaja de esta mejora de desempeño gratuita.

WordPress ahora está tomando la iniciativa para sacar las versiones más recientes de PHP con algunas nuevas herramientas y avisos para promover las versiones de PHP y compatibilidad.

Antes que nada, si usted está utilizando una versión antigua de PHP en su servidor con WordPress 5.1, verá un nuevo widget en su dashboard sugiriendo que descargue una versión más reciente de PHP.

Aviso sobre su versión de WordPress 5.1 PHP en el dashboard

Aviso sobre su versión de  PHP  de WordPress en el dashboard

Si usted tiene a Kinsta como host, es garantía de que no verá este mensaje porque la versión mínima que permitimos de PHP es PHP 5.6. Por el momento, esta advertencia sólo aparecerá para versiones debajo de esta.

Desearíamos que el equipo de WordPress hubiese utilizando una versión más reciente, pero esto sigue siendo una buena decisión para el futuro. También, si da clic en el botón para “Aprender más sobre las actualizaciones de PHP” en este anuncio, los documentos oficiales de WordPress recomiendan PHP 7.3.

El nuevo anuncio de PHP en WordPress 5.1 es un paso al camino correcto. 👍 Esto ayudará a motivar a los hosts y usuarios a adoptar versiones más recientes de PHP.Click to Tweet

Chequeos de Compatibilidad de Versión de PHP para Plugins y Temas

Más allá de la recomendación que da WordPress en el dashboard, WordPress 51 también agrega un chequeo forzoso de compatibilidad con PHP cuando decide instalar un nuevo plugin o tema. ¡Esto es fantástico para desarrolladores!

Por un tiempo, los desarrolladores de plugins de WordPress habían podido establecer un requisito mínimo para la versión de PHP como un comentario en el encabezado del plugin. Sin embargo, hasta ahora, esto ha logrado nada, más que mostrar la versión mínima requerida de PHP que desarrollador se compromete en soportar.

En WordPress 5.1, si uno trata de instalar un nuevo plugin o tema de WordPress.org, donde el desarrollador ha establecido una versión mínima de PHP más reciente que la versión en su servidor, usted verá un mensaje diciendo que este “Plugin no funciona con su versión de PHP. Aprenda más sobre como actualizar su PHP.”

Adicionalmente, no se le permitirá instalar el plugin. En ese momento, usted puede evitar esto al descargar manualmente el ZIP del repositorio e instalar un plugin de esa manera. Pero en realidad – ¡sólo actualice su versión de PHP!

Chequeo de compatibilidad de PHP para plugins

Chequeo de compatibilidad de PHP para plugins

Protección Contra White Screen of Death

WordPress 5.1 fue programado para introducir una nueva función llamada “Protección contra errores fatales” el cual le protegería contra el la pantalla blanca de la muerte de WordPress durante una actualización de PHP.

Desafortunadamente, esta función fue eliminada del lanzamiento de WordPress 5.1 en el último minuto. Sin embargo, esto fue por una buena razón.

“El mecanismo de protección contra errores fatales explicado aquí, ha sido removido del lanzamiento de la versión 5.1 ya que tenía varias fallas críticas, las suficientes para posponer esta función. Un nuevo plan para corregir estos problemas viene en camino, a través de #46130 y la intención es lanzarlo junto con WordPress 5.2”

Felix Arntz
Felix Arntz, Equipo Principal de WordPress
make.wordpress.org

Con esta protección, WordPress reconocerá cuando un error fatal ocurre y pausará el tema o plugin problemático en el dashboard de admin de WordPress para que usted aún pueda iniciar sesión en el backend de su sitio y (esperemos) arreglar el problema. Para usuarios no tan conocedores, esta es una excelente nueva función una vez que ya terminen de arreglar todos sus problemas.

Si su sitio ha experimentado problemas durante las actualizaciones de PHP, lucirá como se muestra abajo, en el front-end, pero aún así, podrá ingresar en el backend para arreglar el problema.

Protección contra errores fatales en WordPress 5.1

Protección contra errores fatales en WordPress 5.1

Desempeño Mejorado en el Editor de Bloques

Desde el lanzamiento inicial del editor de bloque de Gutenberg en WordPress 5.0, el equipo de Gutenberg ha estado trabajando muy duro para mejorar el editor de bloques. Si usted recuerda nuestros benchmarks anuales de PHP, hemos descubierto que WordPress 5.0 y 5.02 eran mucho más lentos que WordPress 4.9.8. ¡Eso es nada bueno! Pero tranquilo, el equipo de WordPress está trabajando en solucionar esto.

Hubo un poco de confusión al momento en que el equipo de Gutenberg lanzó Gutenberg 5.1 al mismo tiempo en que el equipo principal de WP lanzó WordPress 5.1.

A pesar de los números idénticos en sus versiones, WordPress 5.1 no incluye Gutenberg 5.1. En cambio, WordPress 5.1 incluye Gutenberg 4.8.

Y así, los cambios más drásticos al editor de bloque en WordPress 5.1 fueron implementados para mejorar el desempeño. Comparado a WordPress 5.0, usted debería ver tiempos de carga más rápidos en el editor y un tiempo de evento más corto de KeyPress.

Pero aún hay más buenas noticias. El desempeño del editor de bloques mejorará aún más una vez que las versiones más recientes de Gutenberg se unan al core – usted podrá ver una comparación del desempeño de distintas versiones de Gutenberg a continuación (recuerde – WordPress 5.1 incluye Gutenberg 4.8 – así que ahorita es en donde estamos)

Benchmark de desempeño de Gutenberg para distintas versiones

Benchmark de desempeño de Gutenberg para distintas versiones

Cambios para Desarrolladores

Más allá de las nuevas funciones de usuario mostradas arriba, WordPress 5.1 también incluye algunas nuevas funciones para desarrolladores de WordPress.

Metadatos Multisitio

WordPress 5.1 agrega una nueva tabla de bases de datos para almacenar los metadatos asociados con los sitios. Aprenda más.

¿Luchando con el tiempo de inactividad y los problemas de WordPress? Kinsta es la solución de alojamiento diseñada para ahorrarle tiempo! Vea nuestras características

Cron API

La Cron API ahora tiene nuevas funciones para ayudar con datos entrantes. También tendrá nuevos filtros para modificar el almacenamiento de cron. Aprenda más.

Procesos de la Nueva Versión de JavaScript

WordPress 5.1 ofrece una opción de una versión reciente de JavaScript. Puede aprender más sobre retoques específicos aquí.

Cómo Actualizar a WordPress 5.1

Ya que cada sitio de nuestros clientes es distinto, siempre recomendamos que utilicen uno de nuestros entornos de staging. Usted puede clonar su sitio en vivo en cuestión de segundos y poner a prueba WordPress 5.1 con su tema y plugins existentes para revisar la compatibilidad. También puede tomar un backup manual antes de actualizar su sitio en producción, sólo para estar seguro.

Para actualizar WordPress 5.1 simplemente de clic en el icono de actualizaciones en el dashboard de admin de WordPress. Y de clic en el botón de “Actualizar Ahora”. Mientras su sitio está siendo actualizado, estará en modo de mantenimiento. Tan pronto como sus actualizaciones hayan sido completadas, su sitio regresará a la normalidad.

Cómo actualizar a WordPress 5.1

Cómo actualizar a WordPress 5.1

Si todo sale bien con la actualización usted debería ver la pantalla de “Qué Hay de Nuevo”. ¡Eso es todo! Rápido y sencillo.

-La pantalla de bienvenida de WordPress 5.1

La pantalla de bienvenida de WordPress 5.1

Después de dar clic en el dashboard usted recibirá un mensaje para actualizar su base de datos a la versión más reciente. Simplemente haga clic en el botón de “Actualizar la Base de Datos de WordPress” y estará listo.

Se requiere una actualización de la base de datos

Se requiere una actualización de la base de datos

Arreglando Problemas con una Actualización de WordPress

Cuando las personas actualizan a versiones mayores de WordPress, siempre habrá algunos que experimentarán ciertos problemas, y eso es debido a los miles de plugins distintos y temas que actualmente co-existen en el mercado. Aquí le dejamos algunas formas para arreglar problemas comunes.

Resumen

Mientras que no han habido grandes novedades en esta versión, WordPress 5.1 agregó algunas buenas funciones para conseguir sitios de WordPress más saludables.

El enfoque en las versiones de PHP probablemente empujará a un gran porcentaje de usuarios de WordPress, quienes utilizan versiones antiguas de PHP a actualizarlas por versiones más recientes, y las mejoras del editor de bloque son más que bienvenidas.

¿Qué piensa de WordPress 5.1? ¿Algo le interesó? ¿Qué le gustaría que incluyera?


Si le ha gustado este artículo, entonces le encantará la plataforma de Kinsta WordPress hosting. Acelere su sitio y reciba soporte 24/7 de nuestro equipo de WordPress veterano. Nuestra infraestructura potenciada por Google Cloud se centra en escalamiento automático, rendimiento y seguridad. ¡Déjenos mostrarle la diferencia con Kinsta! Conozca nuestros planes