Nous ne prenons aucun plaisir à bannir les plugins. Cependant, nous avons optimisé notre plateforme pour la haute performance, la fiabilité et la sécurité. Pour cette raison, certains plugins ne sont pas autorisés ou ne fonctionneront pas correctement dans l’environnement Kinsta. En général, nous n’autorisons pas la mise en cache, la sauvegarde ou les plugins d’articles relatifs.

Si un plugin est sur notre liste, c’est parce que notre équipe d’administrateurs système a identifié un problème avec lui. Ces problèmes sont généralement liés à la performance ou à la fonctionnalité. Nous travaillons toujours avec des développeurs de plugins tiers pour assurer la compatibilité avec notre plateforme. Par exemple, WP Rocket figurait autrefois sur notre liste d’interdiction et maintenant nous sommes partenaires avec eux.

Plugins Bannis

Plugins de cache

L’utilisation de plugins de mise en cache détériorera les performances et, dans la plupart des cas, ne fonctionnera pas sur notre plateforme. Nous avons déjà implémenté différents types de cache au niveau du serveur, à la fois le cache d’objets et le cache de pages, ce qui est bien mieux que ce que n’importe quel plugin peut faire au niveau PHP. En savoir plus sur la façon dont nous gérons la mise en cache de WordPress.

  • Cache Enabler
  • WP Fastest Cache
  • LiteSpeed Cache

Exception : Nous supportons WP Rocket en versions 3.0 et supérieures. Leur fonctionnalité de mise en cache sera automatiquement désactivée lorsque vous serez chez Kinsta. Ceci vous permet d’utiliser notre solution de mise en cache intégrée tout en utilisant les autres fonctionnalités d’optimisation que WP Rocket a à offrir.

Plugins de sauvegarde

Kinsta fournit déjà des sauvegarde automatiques et téléchargeables quotidiennement pour tous vos sites sur votre compte, donc aucun plugin de sauvegarde n’est nécessaire. Ils peuvent également causer des problèmes de performance inutiles et consommer votre bande passante.

Note : Cette liste n’est pas exhaustive ; toutes les sauvegardes non incrémentielles ne sont pas autorisées.

  • All-in-One WP Migration
  • BackupBuddy
  • BackWPup
  • Snapshot
  • Updraft
  • WP DB Backup
  • WP DB Backup Made

Plugins d’optimisation d’images

Nous n’autorisons pas les plugins d’optimisation d’images basés sur les serveurs ni les utilitaires ou paquets/logiciels en raison de leur impact sur les performances. Cela inclut également l’installation de paquets à utiliser par les scripts d’optimisation d’images. Notre article sur l’optimisation d’images comprend de nombreux plugins WordPress que vous pouvez utiliser qui font la compression des images sur des serveurs cloud tiers. C’est bon à utiliser chez Kinsta.

Plugins de performances

  • WordPress Minify
  • P3 Profiler
  • Optimize Database after Deleting Revisions
  • WordPress GZIP Compression: GZIP est déjà activé sur tous les serveurs Kinsta.
  • WP-Optimize
  • JCH Optimize (raisons : stress PHP constant, utilisation de bande passante élevée, ne peut pas mettre en cache, ne peut pas optimiser pour CDN)

Plugins divers

  • Allow PHP Execute
  • Dynamic Widgets
  • Exec-PHP
  • Inactive User Deleter
  • Pipdig Power Pack (P3)
  • WP RSS Multi Importer
  • WordPress Popular Posts

Plugins de sécurité

De nombreux plugins de sécurité causent des problèmes de performance en raison de leurs fonctionnalités de scan et d’activations permanentes. Une autre raison est la façon dont notre infrastructure est mise en place chez Kinsta. De nombreuses fonctionnalités des plugins de sécurité, telles que le blocage IP, le blocage géographique, etc., ne fonctionneront pas comme prévu en raison du fait que nous utilisons Google Cloud Load Balancers. Nous avons implémenté beaucoup de ces outils tels que le blocage d’IP dans notre tableau de bord MyKinsta car ils doivent être configurés différemment.

Nous vous recommandons également d’utiliser une solution comme Cloudflare ou Sucuri, avec Kinsta, si vous avez besoin d’une protection supplémentaire ou si vous avez besoin d’aide pour diminuer le trafic des robots et/ou des proxys. Jetez un coup d’œil à notre blog sur la façon dont Sucuri a aidé à atténuer une attaque DDoS facilement.

  • Login Wall

Plugins pour les médias sociaux

  • Facebook Instant Articles & Google AMP Pages par PageFrog
  • Facebook Open Graph, Google+ and Twitter Card Tags

Plugins Nulled

Les plugins Nulled font généralement référence à des plugins ou thèmes WordPress premium qui ont été piratés ou qui contiennent du code modifié conçu pour nuire ou collecter des informations. Ceux-ci sont obtenus à partir d’un site Web tiers (et non de l’auteur ou du créateur original) et sont parfois faits pour fonctionner sans clé de licence.

Nous offrons une garantie de correction de piratage chez Kinsta, mais cette garantie ne s’applique pas si vous utilisez des plugins Nulled.

Plugins incompatibles

  • WooCommerce Amazon & eBay Integration: Nécessitent la fonction PHP proc_open qui est désactivée dans notre environnement pour des raisons de sécurité.

Liste complète

N’hésitez pas à comparer la liste ci-dessous avec votre dossier /wp-content/plugins/ actuel.

all-in-one-wp-migration
allow-php-execute
backupbuddy
backwpup
better-wordpress-minify
cache-enabler
codistoconnect
dynamic-widgets
eww-image-optimizer
exec-php
inactive-user-deleter
jch-optimize
login-wall
liteSpeed-cache
p3
p3-profiler
pagefrog
rvg-optimize-database
snapshot
updraft
wonderm00ns-simple-facebook-open-graph-tags
wordpress-gzip-compression
wordpress-popular-posts
wordpress-rss-multi-importer
wp-db-backup
wp-db-backup-made
wp-optimize
8
Partages